Buyer Guides are currently unavailable
Incident Report for Vendr, Inc.
Resolved
This is confirmed resolved. Thanks for your patience. Please reach out to support if you have any further questions.
Posted Jan 11, 2024 - 17:21 EST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jan 11, 2024 - 13:34 EST
Identified
We are working on a solution and will update you as soon as this is resolved. Thanks for your patience.
Posted Jan 11, 2024 - 11:56 EST
This incident affected: Vendr Customer Portal (Vendr App).