Vendr App - Unable to Add Products
Incident Report for Vendr, Inc.
Resolved
The incident with adding products has been resolved. Thank you so much for your patience with this matter!
Posted Oct 17, 2023 - 16:08 EDT
Identified
The issue has been identified and a fix is in the works. Thanks again for your continued patience!
Posted Oct 17, 2023 - 14:54 EDT
Investigating
We are currently investigating an issue with trying to add products. We appreciate your patience while we look into this matter.
Posted Oct 17, 2023 - 14:04 EDT
This incident affected: Vendr Customer Portal (Vendr App).