Vendr is Currently unavailable
Incident Report for Vendr, Inc.
Resolved
Thanks for your patience, this is resolved.
Posted Feb 01, 2024 - 16:31 EST
Monitoring
We are back up and monitoring! Thanks for your patience!
Posted Feb 01, 2024 - 15:28 EST
Investigating
We're currently investigating an issue affecting our platform. At this time, app.vendr.com is not available. We are working quickly to resolve this issue.
Posted Feb 01, 2024 - 15:08 EST
This incident affected: Vendr Customer Portal (Vendr App).