Vendr portal is unavailable
Incident Report for Vendr, Inc.
Resolved
This incident has been resolved.
Posted Sep 15, 2023 - 05:49 EDT
Investigating
We're currently investigating an issue affecting our platform. At this time, users are unable to log in to app.vendr.com. We are working quickly to resolve this issue.
Posted Sep 15, 2023 - 05:26 EDT
This incident affected: Vendr Customer Portal (Vendr App).