Intake submission request unavailable
Incident Report for Vendr, Inc.
Resolved
This incident has been resolved.
Posted Jul 27, 2023 - 14:25 EDT
Monitoring
Hey there, looks like we are back up and running. Please reach out to support if you have any further difficulty. Thanks for your patience!
Posted Jul 27, 2023 - 13:14 EDT
Investigating
We are currently investigating an issue with intake submission. You may be experiencing problems submitting new purchase and renewal requests. Our team is working quickly to resolve this issue.
Posted Jul 27, 2023 - 12:41 EDT
This incident affected: Vendr Customer Portal (Vendr App).