The Vendr app is currently unavailable
Incident Report for Vendr, Inc.
Resolved
We are back up, thanks for your patience and as always, please reach out to support if you have any questions!
Posted Sep 28, 2023 - 16:45 EDT
Identified
We're currently investigating an issue affecting our platform. At this time, app.vendr.com is not available. We are working quickly to resolve this issue.
Posted Sep 28, 2023 - 16:24 EDT
This incident affected: Vendr Customer Portal (Vendr App).