app.vendr.com is currently unavailable
Incident Report for Vendr, Inc.
Resolved
This incident has been resolved.
Posted Apr 16, 2024 - 08:45 EDT
Investigating
We're currently investigating an issue affecting our platform. At this time, app.vendr.com is not available. We are working quickly to resolve this issue.
Posted Apr 16, 2024 - 08:33 EDT
This incident affected: Vendr Customer Portal (Vendr App).